Jump to content


Photo
- - - - -

Got my new fruit machine, but...


  • Please log in to reply
25 replies to this topic

#1 RHM

RHM

    Junior Member

  • Silver Supporters
  • 240 posts

Posted 08 December 2018 - 10:34 pm

Always a BUT!!

 

£1 coins payout as they should, but 20p's don't.

 

It's all cash by the way, 5p play £6 cash jackpot despite saying tokens over £3, obviously an upgrade.

 

Upon investigation, in test mode checking the payouts, the x2 token solenoids fire and the £1, but nothing for the 20p!

 

I take out the 20p solenoid to look at it, it seems to have melted or to be honest it looks like wax has been poured on it (photo available upon request).

 

So I think, I'll use a token solenoid instead, swapping that plastic cover so that the 20p tube will fit in etc. Still nothing, despite a pre-working solenoid....I check the fuses in the power supply box (I think in a pre owned machine replacing one of those seemed to work), it didn't, I replaced all fuses.

 

When you collect say 20p it just clicks up the meters and no 20p comes out.

 

Any ideas guys as to why it's not paying 20ps, I've had a few drinks so will check back tomorrow when a bit more lucid. 

 

 



#2 richy1976

richy1976

    The furniture

  • Silver Supporters
  • 2,211 posts

Donator

Posted 08 December 2018 - 11:28 pm

Check the wiring back to the mpu4 triac plug first see if wire not come off or plug is loose.

If it's not that would be best take board out and check for battery damage.
More than likely battery would have leaked.
And I'm sure triacs are directly below.

Edited by richy1976, 08 December 2018 - 11:35 pm.


#3 RHM

RHM

    Junior Member

  • Silver Supporters
  • 240 posts

Posted 09 December 2018 - 10:19 am

The wires look OK.

 

I took the MPU4 out.

 

Looking at the battery, it looks like it needs replacing or fly wiring (if that's possible).

 

PL6 TRIACS section looks ok.

 

T15 / T13 looks a little corroded (is this the bit that does the payouts?).

 

I have tried to wipe off some corrosion. 

 

Putting it back now.

Attached Files



#4 Mavroz

Mavroz

    odd job man...

  • Layout Creator
  • PipPipPip
  • 850 posts

Posted 09 December 2018 - 11:49 am

Plenty of battery leakage corrosion. More than enough to cause issues.

 

Possibly/probably eaten through the tracks and destroyed the drive transistors.

 

Cleanup / neutralise the battery leakage on all areas concerned, repair damaged tracks, replace damaged components.

 

Or source a working replacement.



#5 RHM

RHM

    Junior Member

  • Silver Supporters
  • 240 posts

Posted 09 December 2018 - 12:16 pm

Ha, how do you replace the damaged tracks?

 

Anyone got a spare MPU4 :D



#6 richy1976

richy1976

    The furniture

  • Silver Supporters
  • 2,211 posts

Donator

Posted 09 December 2018 - 01:23 pm

Its probably best to use thin wire and link them back together that way.

Any bits of green you see are battery leakage.

I only have a mod 2 spare, and i dont think it will work with the sound in that.

Good person to contact is booze.net through the mecca, i have had 2 boards off him in the past with coincell battery, still going about 4 years later on the same battery.

Also got the mod2 from him which is also coincell.

Theses cost me £60 each about 4 years ago, but good boards of him.


Edited by richy1976, 09 December 2018 - 01:24 pm.


#7 RHM

RHM

    Junior Member

  • Silver Supporters
  • 240 posts

Posted 09 December 2018 - 02:18 pm

I wouldn't know were to start with a thin wire! Think i'd need a thicko guide how to do it.

 

It's a BWB not a Barcrest, maybe that board you mention may work?

 

Are we for sure its the board as the £'s still payout.

 

Anything else I can check?



#8 richy1976

richy1976

    The furniture

  • Silver Supporters
  • 2,211 posts

Donator

Posted 09 December 2018 - 02:58 pm

Cant be 100% its the board.

I had one were it was firing a token out on boot up, changed the caps in the psu and it was ok.

 

Best bet is the mecca mate, booze has go thread somewhere on there about mpu4 repair.

If i was after a new board i would contact him first personally.



#9 RHM

RHM

    Junior Member

  • Silver Supporters
  • 240 posts

Posted 09 December 2018 - 04:13 pm

Thank you, when I get the chance i'll pop on over.

 

For the moment, i'll try and round wins up to a £1 lol.

 

With regards to the £1, the cheapest reprogramming I have found is £20 for the coin mech and a fiver for 20 bulbs.

 

Be up and running good and proper soon! :p

 

Even on 76% it gives a good game, still seems to generous to be honest.



#10 Mavroz

Mavroz

    odd job man...

  • Layout Creator
  • PipPipPip
  • 850 posts

Posted 09 December 2018 - 04:41 pm

Cant be 100% its the board.

I had one were it was firing a token out on boot up, changed the caps in the psu and it was ok.

 

Best bet is the mecca mate, booze has go thread somewhere on there about mpu4 repair.

If i was after a new board i would contact him first personally.

 

Must have struck lucky for now with sorting the ripple on the supply with the caps.. Firing of sol on startup is is bad pre drive transistor or triac starting to fail.



#11 RHM

RHM

    Junior Member

  • Silver Supporters
  • 240 posts

Posted 09 December 2018 - 04:57 pm

Can these boards have the battery put elsewhere? i.e. fly wiror



#12 richy1976

richy1976

    The furniture

  • Silver Supporters
  • 2,211 posts

Donator

Posted 09 December 2018 - 04:59 pm

 

Must have struck lucky for now with sorting the ripple on the supply with the caps.. Firing of sol on startup is is bad pre drive transistor or triac starting to fail.

Still going strong after about 4 years.


Yes flywire.

Mine takes these batteries, but you need to solder a holder on.

 

https://www.ebay.co....acbkA:rk:3:pf:0



#13 RHM

RHM

    Junior Member

  • Silver Supporters
  • 240 posts

Posted 09 December 2018 - 07:44 pm

God this machine is a HYPER VYPER!!! I lowered it from 82% to 76% as it playing too generous! Now on 76% i'm averaging £1 in and £10 something out. What's up with it!?


... I can only compaire it to demo mode.



#14 richy1976

richy1976

    The furniture

  • Silver Supporters
  • 2,211 posts

Donator

Posted 09 December 2018 - 09:04 pm

It might have ram cleared.
Can take very long time to level back to set percentage.
Turn it off with credits on, leave off for a bit turn back on and see if credits are still there.

#15 fuzion

fuzion

    Part of the furniture

  • Regulars
  • 1,658 posts

Posted 10 December 2018 - 01:28 am

You can tell a ram clear on this era Barcrest....   Triple Bar, Red 7, Red 7.     I doubt it would pay £10 with only a £1 in even on a ram clear....  I've played many ram cleared units back in the day and they would be playing but not as quickly as £1 in.

 

J


// stumblin' in the neon groves


#16 RHM

RHM

    Junior Member

  • Silver Supporters
  • 240 posts

Posted 10 December 2018 - 08:25 pm

Yes, I've seen that, a cafe had a road hog in many years ago and every morning it was on BAR 77, a quid in and a £6-9 return. They never cottoned on lol.

 

Anyway's, had a few plays before, THIS MACHINE IS PAYING OUT WAY TOO MUCH!!! When I got it, I changed it from 82% to 76%, this is a savings machine, so want it realistic.

 

The best I have done is £1 in, £18.20 out, not to mention the other previous winnings, and a few free games it spits out when bitten. Then a dead £1 so I'm thinking it's going back to normal, and then a JACKPOT and BLUE sevens etc.

 

Collecting a feature so as feature blitz or skill stopper repeats at least three times for around a tenner. Regular feature entries one after the other, being able to hi-lo gamble from 40p to £6 on unrealistic numbers.

 

How long can this go on for?

 

What caused the ram clear, is my mate was playing it for real and I unplugged the coin mech to look at it, it error'd and reset, he lost his credits and goes and BAR 77'd, since then it's been on one, I CAN'T LOSE.

 

I'm scrapping my CASINO night lol.

 

When playing it before it started on one I got the blue sevens and it prevented me from gambling to £6, strange as its all cash. Looking at the dip settings the token inhibit had been accidentally put on, so it wouldn't let me gamble any further, a quick flick and it was back to normal and then it was super sevens after super sevens and the above lol.

 

Could it possible some settings are wrong and its paying out too much? Actually no fun when you win!



#17 richy1976

richy1976

    The furniture

  • Silver Supporters
  • 2,211 posts

Donator

Posted 10 December 2018 - 09:50 pm

Never unplug or plug nothing mate when machine has power.

#18 RHM

RHM

    Junior Member

  • Silver Supporters
  • 240 posts

Posted 13 December 2018 - 12:39 pm

SOWWY



#19 TommyC

TommyC

    Layout Designer

  • Layout Creator
  • PipPipPipPipPip
  • 2,436 posts

Posted 14 December 2018 - 12:06 am

The battery is dead and needs changing it won't stop ram.clearing until you do this. The ram could also be faultythis would cause ridiculous layouts but can also go the other way were it won't pay hardly anything.


Hold the bells mate.

#20 fuzion

fuzion

    Part of the furniture

  • Regulars
  • 1,658 posts

Posted 14 December 2018 - 09:55 am

Yes, I've seen that, a cafe had a road hog in many years ago and every morning it was on BAR 77, a quid in and a £6-9 return. They never cottoned on lol.

 

Anyway's, had a few plays before, THIS MACHINE IS PAYING OUT WAY TOO MUCH!!! When I got it, I changed it from 82% to 76%, this is a savings machine, so want it realistic.

 

The best I have done is £1 in, £18.20 out, not to mention the other previous winnings, and a few free games it spits out when bitten. Then a dead £1 so I'm thinking it's going back to normal, and then a JACKPOT and BLUE sevens etc.

 

Collecting a feature so as feature blitz or skill stopper repeats at least three times for around a tenner. Regular feature entries one after the other, being able to hi-lo gamble from 40p to £6 on unrealistic numbers.

 

How long can this go on for?

 

What caused the ram clear, is my mate was playing it for real and I unplugged the coin mech to look at it, it error'd and reset, he lost his credits and goes and BAR 77'd, since then it's been on one, I CAN'T LOSE.

 

I'm scrapping my CASINO night lol.

 

When playing it before it started on one I got the blue sevens and it prevented me from gambling to £6, strange as its all cash. Looking at the dip settings the token inhibit had been accidentally put on, so it wouldn't let me gamble any further, a quick flick and it was back to normal and then it was super sevens after super sevens and the above lol.

 

Could it possible some settings are wrong and its paying out too much? Actually no fun when you win!

Are you sure it's all cash, have you had the jackpot?   Usually not being able to gamble to the jackpot is because it is set to token payout and the it thinks tokens are low.  You can usually tell via the number reel on these machines.  If it's low in tokens it is impossible to achieve a jackpot and the number reel will spin in 4's and 9's all the time.

 

There should be some all cash roms for your machine.  It all depends on the manufacturer and what version yours is running.

 

J

 

J


Doh!!!  I re-read and noticed the token inhibit.

 

J


// stumblin' in the neon groves





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users