Jump to content


Photo
- - - - -

Top Box Games MFME V6 V5


  • Please log in to reply
12 replies to this topic

#1 krayzeestyles

krayzeestyles

    Krayzee Styles

  • Regulars
  • 113 posts

Posted 07 January 2018 - 03:36 PM

Hi, does any one know how to by pass needing an internet connection to run top box games, I tether my metered mobile data via hotspot to my lappy, when my data runs out and I got no internet connection, the games don't work, says 'no comms' or 'no comms to master' Why do I need to be connected to the net to play Hokey Cokey, Party Time, Bullion Bars etc...really annoying!! Have entered my I.P. address and saved the games loads, still comes up the same, 'no comms' no comms to master!!:(
Compulsive gambling is an emotional illness that can never be cured but can be arrested one day at a time.

#2 No1Stoney

No1Stoney

    Senior Member

  • Layout Creator
  • PipPipPip
  • 790 posts

Posted 07 January 2018 - 05:14 PM

Use your local IP? 192.168.x.x



#3 Magz

Magz

    Senior Member

  • Gold Supporters
  • 819 posts

Posted 08 January 2018 - 09:36 PM

As you're having an issue, I am guessing that you don't have any sort of connection other than the tethered mobile connection - so no other wifi - LAN connection etc.

 

To get around this, you just need a network connection that is always on, but doesn't necessarily have Internet along with it.

 

Try this:

 

- Add a Microsoft Loopback Adaptor to your config

 

Google for this - but here's a link for Win10 - http://nil.uniza.sk/...pter-windows-10

Likely similar in other O/S

 

Once added, go to Control Panel - Network Connections and "Change Adapter Settings"

Find the Ethernet x entry which is linked to the Loopback Adapter

Double click entry and change the IPv4 settings to an internal IP (10.11.12.13 would do - leave the mask as 255.255.255.0)

Enter that IP in the MFME config page

Should then work without Internet

 

I tested this quickly on my laptop and it worked. If it doesn't - check your Windows Firewall and make sure MFME.EXE is allowed through.



#4 Wizard

Wizard

    MFME Creator

  • Regulars
  • 473 posts

Posted 10 January 2018 - 05:51 PM

I tried that and unfortunately that won't work either as the Microsoft Loopback Adaptor doesn't support network broadcasting, that's also why 127.0.0.1 doesn't work either.


Warning: This post is mostly my own opinions and may contain irony, if you are obsessed with PAST history you may want to ignore it.


#5 fuzion

fuzion

    Part of the furniture

  • Regulars
  • 1563 posts

Posted 10 January 2018 - 06:00 PM

Can't the poster install a network card?  Even a PCI based one would be ok wouldn't it?

 

J


// stumblin' in the neon groves


#6 Magz

Magz

    Senior Member

  • Gold Supporters
  • 819 posts

Posted 11 January 2018 - 06:39 PM

I tried that and unfortunately that won't work either as the Microsoft Loopback Adaptor doesn't support network broadcasting, that's also why 127.0.0.1 doesn't work either.

 

That's interesting. I tested this on Windows 8.1 doing the following:

 

Disable all network adaptors except the Loopback

Add a static IP to the Loopback network settings

Specify that IP in the MFME config page

 

That works correctly the Hokey Cokey, and I could get Top box wins etc.

 

If this doesn't work for you, I wonder if it's something else I have protocol wise over the default items.

 

Let me know, and I'll build a clean VM and give it a test...



#7 Wizard

Wizard

    MFME Creator

  • Regulars
  • 473 posts

Posted 11 January 2018 - 06:51 PM

What static IP did you choose? I'm running W7 btw


Warning: This post is mostly my own opinions and may contain irony, if you are obsessed with PAST history you may want to ignore it.


#8 Magz

Magz

    Senior Member

  • Gold Supporters
  • 819 posts

Posted 11 January 2018 - 07:11 PM

I set the address 10.11.12.13 (just for fun) on the IPv4 settings on the loopback adaptor and then specified that as the address in MFME...



#9 Wizard

Wizard

    MFME Creator

  • Regulars
  • 473 posts

Posted 11 January 2018 - 07:15 PM

aha, using 10.11.12.13 seems to work fine. I was using 172.16.0.1 and that certainly doesn't. Not sure why that is?

 

That's a good tip, cheers for that, will certainly help some people out :)


Edited by Wizard, 11 January 2018 - 07:16 PM.

Warning: This post is mostly my own opinions and may contain irony, if you are obsessed with PAST history you may want to ignore it.


#10 Magz

Magz

    Senior Member

  • Gold Supporters
  • 819 posts

Posted 11 January 2018 - 07:53 PM

That's really odd as they're both private ranges.

 

Anyway, great that it works :)



#11 Wizard

Wizard

    MFME Creator

  • Regulars
  • 473 posts

Posted 11 January 2018 - 08:13 PM

Yes it's strange but at least we have a solution for the one guy with issues, who knows it might even be faster doing it that way?


Warning: This post is mostly my own opinions and may contain irony, if you are obsessed with PAST history you may want to ignore it.


#12 krayzeestyles

krayzeestyles

    Krayzee Styles

  • Regulars
  • 113 posts

Posted 12 January 2018 - 12:10 AM

As you're having an issue, I am guessing that you don't have any sort of connection other than the tethered mobile connection - so no other wifi - LAN connection etc.

 

To get around this, you just need a network connection that is always on, but doesn't necessarily have Internet along with it.

 

Try this:

 

- Add a Microsoft Loopback Adaptor to your config

 

Google for this - but here's a link for Win10 - http://nil.uniza.sk/...pter-windows-10

Likely similar in other O/S

 

Once added, go to Control Panel - Network Connections and "Change Adapter Settings"

Find the Ethernet x entry which is linked to the Loopback Adapter

Double click entry and change the IPv4 settings to an internal IP (10.11.12.13 would do - leave the mask as 255.255.255.0)

Enter that IP in the MFME config page

Should then work without Internet

 

I tested this quickly on my laptop and it worked. If it doesn't - check your Windows Firewall and make sure MFME.EXE is allowed through.

 

Thank You


Compulsive gambling is an emotional illness that can never be cured but can be arrested one day at a time.

#13 Magz

Magz

    Senior Member

  • Gold Supporters
  • 819 posts

Posted 12 January 2018 - 07:49 PM

No probs :)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users