Jump to content


Photo
- - - - -

Mpu5 error help ?


  • Please log in to reply
5 replies to this topic

#1 treebo88

treebo88

    Newbie

  • New Members
  • 6 posts

Posted 29 August 2017 - 07:35 PM

Firstly my name's Chris this is my first post asking for help , I've been using this forum for my troubles with fruit machines for a while now and I can usually find my answer easily as there's alot of knowlagable fruity lovers here :-) however this problem I cannot wrap my head around..

I have a mpu5 machine that's been giving me issues for a few weeks now. I got it in a non working condition, it gave a battery low/dead error code so I replaced the coin battery and the machine powered up for about 5 minutes and gave a corrupt error aswell as a no I'd card error and character error, so I cleared the mem etc and it worked again for 5 mins and the same result... then nothing , it won't power the game card up at all, I replaced the green battery and then that also worked for a few minutes and it died again, every time I remove and test or replace and test the green battery it works fine for a few mins ... I don't understand what's wrong ? Any ideas at this point would be appreciated ...
I should also add I've tried another game board in this machine and it booted perfectly so the main board is fine I just don't understand how it will boot whenever it likes...

#2 treebo88

treebo88

    Newbie

  • New Members
  • 6 posts

Posted 30 August 2017 - 09:39 AM

Ok so I managed to get this game card to boot by removing it using a different game card to clear the roms (googled idea) and then replacing my card, it worked and played all night I switched it off last night and came back to it today and no go again... same errors

Attached Files



#3 aaamusements

aaamusements

    Grumpy site owner/Admin

  • Administrators
  • PipPipPipPipPip
  • 3326 posts

Posted 30 August 2017 - 07:01 PM

Do you know if the program on the card is contained in removable EPROMS, or is it on flash memory?

#4 richy1976

richy1976

    Part of the furniture

  • Bronze Supporters
  • 1780 posts

Donator

Posted 30 August 2017 - 07:15 PM

The error is to do with the pic chip, with it being a used machine & you aquired it broke, the chip could be missing, blown, wrong.

You can see the chip through a cut out on the mpu it will have a code on it (dont know what machine you got) like BA25 for example.



#5 TommyC

TommyC

    Layout Designer

  • Layout Creator
  • PipPipPipPip
  • 1813 posts

Posted 30 August 2017 - 09:40 PM

Looks like the machine is going ape by barcrest
Hold the bells mate.

#6 fruitman69

fruitman69

    Layout Designer

  • Layout Creator
  • PipPipPip
  • 1079 posts

Posted 31 August 2017 - 08:31 AM

Carefully remove the small pic chip and reseat it back in, that has worked for me before. This is assuming it is the correct one for the game. ( the heat can sometimes make them work up the socket )

 

I also had a CWOranges on site do this at boot up some times and switching on and on again normally worked, however i never got to the bottom of why it came up with the error now and again.


Follow us on facebook http://www.facebook....131728946893342
www.reelsoffun.co.uk




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users