Jump to content


Photo
- - - - -

VFD Display problem


  • Please log in to reply
3 replies to this topic

#1 ant2110

ant2110

    Newbie

  • Regulars
  • 30 posts

Posted 12 October 2017 - 10:21 PM

Hi, 

 

I have a Barcrest Rocky Horror (MPU4) which has developed a VFD fault. 

 

It displays random garbage on the display, sometime its totally blank. 

I've checked all connections from the display back to the MPU4  and are all okay. Also had a prod around to see if any of the other cables would correct the display when moved, looking for a bad connection, but could not find anything. 

 

Occasionally the display will show correctly, There seems to be no pattern to when it is blank / correct / garbage

 

 

Ant advice on what I can try would be appreciated

Ant. 



#2 Mavroz

Mavroz

    odd job man...

  • Layout Creator
  • PipPip
  • 716 posts

Posted 13 October 2017 - 04:06 AM

Battery may have leaked. Display tracks run underneath the battery.

#3 fuzion

fuzion

    Part of the furniture

  • Regulars
  • 1382 posts

Posted 13 October 2017 - 09:05 AM

How long have you had it? Have you checked the state of the battery on the MPU4 board? You would need to disconnect everything and remove the board and get inside to take a look. Almost certain to be battery damage as that machine is from around 1997.

J

#4 edwardb

edwardb

    Junior Member

  • Regulars
  • 173 posts

Posted 31 October 2017 - 02:44 PM

Yep, bad battery, capacitors bulging, shorting of cables on metalwork, but also a lot of VFD corruption was due to "noise" from other components - power supplies were the big one. See if you can get another MPU4 display and test it.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users