Jump to content


Photo

Pay unit err 17 on mazooma monopoly


  • Please log in to reply
3 replies to this topic

#1 Tel

Tel

    Newbie

  • New Members
  • 2 posts

Posted 07 September 2017 - 01:41 pm

Hello to everyone, ​am new to all of this as I haven't worked on a fruit machine for over 30 years.  I recently got given a Mazooma Monopoly wonders of the world machine which is running a scorpion 5 board. It is showing "Pay unit Err 17 as soon as it has initialised.  I have removed the hopper unit and checked for loose connections all seem OK and the unit spins freely by hand.  On the mpu all 7 led's are lit which if I understand correctly means that all voltages are being supplied.  I am hoping someone may have a manual for this machine I could copy and also for any information on where/how I can start to fault find.  The person I got the machine off said that it was working fine until they emptied the hopper and when they switched the machine on it started alarming.



#2 chasnbons

chasnbons

    Junior Member

  • Regulars
  • 1,194 posts

Posted 07 September 2017 - 07:30 pm

There's either a coin stuck in the hopper or the opto's need cleaning, are my guesses.



#3 Tel

Tel

    Newbie

  • New Members
  • 2 posts

Posted 07 September 2017 - 07:33 pm

Thanks for that Chas I have manually turned the unit with coins in it and they came out ok, where abouts are the opto's in the unit



#4 chasnbons

chasnbons

    Junior Member

  • Regulars
  • 1,194 posts

Posted 08 September 2017 - 07:06 am

They are small sensors 4 of them, and are postioned where the coins come out of the hopper.

 

They look like little black shiny black dots.

 

You may need to dismantle the hopper a bit to get to them.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users